Airplay incommunicado

Balthazar B

Major Contributor
Nov 1, 2022
Ran into an odd Airplay issue. I've reported it to WiiM, and now sharing it here for thoughts/suggestions:
  • Have two WiiM Pros, and starting out one (Dee) was on WiFi, the other (Dum) on Ethernet.
  • From the Music application on a Macbook, could see both WiiMs as Airplay devices. The Mac and WiiMs are on the same network/VLAN, and all on current OS/firmware releases.
  • I could direct music to Dee successfully, but got a connection failure warning when trying to select Dum (cannot connect to Dum, unable to play audio).
  • So hypothesizing that Dum's Ethernet connection could be the issue, I turned on WiFi on Dum, disconnected Ethernet, and rebooted.
  • Dee, Dum, and Mac now all on the same network/SSID.
  • In the WiiM Home app, I did need to re-establish the connection to Dum, but its settings were as before. On both WiiMs, IP6 is set to On.
  • But now from the Mac, while I can continue to see Dee in the Music app, Dum is nowhere to be found. Rebooting the WiiM, Mac, etc., doesn't fix the issue. I can see all the devices connected to my WiFi in the router's control screen.
  • Unfortunately, I don't have another Apple device on hand to see if the issue can be isolated to the Mac.
Questions? Suggestions on other troubleshooting steps to try?

Do both Wiim's appear online in the Wiim app?

Yes. They're identical in all respects in terms of configuration, etc. (including WiFi to the same AP), so it may be a subtle fault revealing itself with one of the devices. I've tried a bunch of things to try and narrow down the root cause and updated WiiM, but have found nothing definitive. I'm still waiting for someone from @WiiM Support to get back to me (WiiM folks, the ticket is #7466 if you'd like to take a look).
I just found this thread. I just posted about an issue I'm experiencing from MacOS that I can see, but not connect, to my Wiims from the Music app. However, as a workaround, Airfoil works flawlessly to stream to all devices. Of course this only intensifies my confusion.