Experiencing Multiple Issues


Feb 20, 2023
My issues include:

1. In the WiiM app, tracks cutting off early and then skipping not to the next track but the track after. WiiM support tried to fix this by resetting my DNS but this did not work.

2. The first problem above is fixed by using Tidal Connect, but that is also buggy, crashing that app or manifesting in other weirdness like the app not recognizing what song is playing.

3. Both apps “forgetting” the device and having to go through set up again.

4. Mostly recently, the device mo longer recognizing it is connected via Ethernet.
My experience
1 - I don't use the wiim app.
2- I do use tidal connect. Yes, the tidal app is a bit buggy... Very occasionally I've had it skip part way through a track to the next one, not sure i've seen it skip to the one after.
Sometimes tidal just crashes, but not enough to really frustrate me.
Yes, sometimes it takes what seems like ages, but is probably only 20 secs, to show the right album art or track details.
Nothing to do with wiim, as this happens when just using tidal on my tablet.
3 - never experienced this, but sometimes I need to close tidal and start it again for it to actually connect to the wiim.
Again, not a wiim issue as I sometimes have the same issue with a bluesound node.
4 - is not applicable to me, I have a mini.

So yes, the tidal app's school report says 'could do better', yet for some reason I still prefer to use tidal over anything else I've tried with the mini.
This is happening to me as I play a podcast using Spotify Connect - it skips to the episode after the next episode (i.e. it will go from episode 3 (now playing) to the beginning of episode 5); and it does this very often when I play one particular episode of one podcast that I stopped partway through previously.

I have also found that streaming audio via YouTube with AirPlay often causes the video to stutter and the AirPlay connection to drop.

This all started after I went away on holiday for two weeks and came back. Restarting (both the WiiM and my M1 MacBook) didn't seem to help, and neither did resetting the WiiM to factory settings.

I've tried turning off "5GHz only"; let's see...