Gapless mode (setNextURI) issues for UPnP interface

onlyoneme

Major Contributor
Joined
Oct 20, 2022
Messages
2,150
@WiiM Support

Gapless mode seems to behave unpredictable for both WiiMs especially when audio streams are controlled by UPnP bridge plugin in LMS.
Author of the plugin suspects that

"The issue is that the UPnP stack of the WIIM (I don't have one) seems to be a very precarious. For example, per discussion with @d6dg it refuses (sometimes) to process a "next URI" command 20 seconds before the current track ends. I guess something like that they have some internal buffers or process (decode) that when emptied or terminated, sets the machine in a state where it cannot process "next URI"."

Can you please look at this issue to find out if it could be somehow fixed?
 
I can confirm the poor performance of the Pro when linked to my audio setup from LMS via the UPnP plugin.

If I make a playlist within LMS's Qobuz plugin and then start to play it via the UPnP bridge, hardly anything plays as expected. For example, some tracks are skipped entirely (it jumps to the next one instead). Some tracks stop after a few seconds and the playlist does not continue. Some tracks stop at their end, and again the playlist does not continue. None of this happens always, but certainly very often—and often enough for it to be impossible as a way for using the Pro.

It's a mess.

Please WiiM sort out your UPnP.

Do not just acknowledge it's a problem and then do nothing.

Even better, implement LMS/Squeezelite into the WiiM setup. It's way down your road map and it should be a priority.

That would be a much, much better way to clear up this problem, because we LMS users then would not have to take our chances with UPnP.

Please!
 
I can confirm the poor performance of the Pro when linked to my audio setup from LMS via the UPnP plugin.

If I make a playlist within LMS's Qobuz plugin and then start to play it via the UPnP bridge, hardly anything plays as expected. For example, some tracks are skipped entirely (it jumps to the next one instead). Some tracks stop after a few seconds and the playlist does not continue. Some tracks stop at their end, and again the playlist does not continue. None of this happens always, but certainly very often—and often enough for it to be impossible as a way for using the Pro.

It's a mess.

Please WiiM sort out your UPnP.

Do not just acknowledge it's a problem and then do nothing.

Even better, implement LMS/Squeezelite into the WiiM setup. It's way down your road map and it should be a priority.

That would be a much, much better way to clear up this problem, because we LMS users then would not have to take our chances with UPnP.

Please!
I think it’s fair to say adding Squeezelite would create a lot of sales as the current source of LMS players is very limited.
 
I confirm that gapless playback is broken in UPnP. And also the other playback problems mentioned above.

Please provide your roadmap for fixing it.

I'm writing a review for my audiophile blog and for the audio forum which i'm administrating, and this bug is a blocker so I can't recommend buying Wiim as long as no fix is planned.

Most users are using Android smartphones so the UPnP protocol is the most usual way to use Wiim. It should perform as well as AirPlay.

All the best
 
Last edited:
I confirm that gapless playback is broken in UPnP. And also the other playback problems mentioned above.

Please provide your roadmap for fixing it.

I'm writing a review for my audiophile blog and for the audio forum which i'm administrating, and this bug is a blocker so I can't recommend buying Wiim as long as no fix is planned.

Most users are using Android smartphones so the UPnP protocol is the most usual way to use Wiim. It should perform as well as AirPlay.

All the best
Is it only Symfonium you're having this problem with?
The only problem I've had with gapless playback is with tracks of less than 40 seconds, but that's just a scenario I use for testing.
 
Is it only Symfonium you're having this problem with?
The only problem I've had with gapless playback is with tracks of less than 40 seconds, but that's just a scenario I use for testing.
For the moment I only tested with Symfonium, as Symfonium implementaton of gapless UPNP playback is clean : for example I tested it on my B&W Zeppelin which is doing perfect gapless UPNP playback with Symfonium.

Have you made some tests with Symfonium ?
 
Have you made some tests with Symfonium ?
The album I use to test gapless playback with consists of 4 40 second (because any shorter and gapless doesn't work) WAV tracks.
When I played the album using Synfonium the first track transition was gapless but the metadata in the control point didn't update, and on the next transition the opposite occured, it wasn't gapless but the metadata did update!

I primarly use BubbleUPnP which has been flawless (although WiiM does have problems with BubbleUPnP server) as has Hi-Fi Cast when I've tried it, but mconnect hasn't played gaplessly (although the metadata did update) so it's not just Symfonium.
 
The album I use to test gapless playback with consists of 4 40 second (because any shorter and gapless doesn't work) WAV tracks.
When I played the album using Synfonium the first track transition was gapless but the metadata in the control point didn't update, and on the next transition the opposite occured, it wasn't gapless but the metadata did update!

I primarly use BubbleUPnP which has been flawless (although WiiM does have problems with BubbleUPnP server) as has Hi-Fi Cast when I've tried it, but mconnect hasn't played gaplessly (although the metadata did update) so it's not just Symfonium.
Symfonium app seems to have the same issues with the WiiM as LMS - no metadata refresh in the gapless mode and switching to the gapped playback with metadata refreshed when gapless playback failed.
 
The album I use to test gapless playback with consists of 4 40 second (because any shorter and gapless doesn't work) WAV tracks.
When I played the album using Synfonium the first track transition was gapless but the metadata in the control point didn't update, and on the next transition the opposite occured, it wasn't gapless but the metadata did update!

I primarly use BubbleUPnP which has been flawless (although WiiM does have problems with BubbleUPnP server) as has Hi-Fi Cast when I've tried it, but mconnect hasn't played gaplessly (although the metadata did update) so it's not just Symfonium.
Yes, I confirm having the same behaviour
 
Any progress on this blocker bug ?

The Symfonium dev may be helpful. He usually is ;)
 
I confirm that gapless playback is broken in UPnP. And also the other playback problems mentioned above.

Please provide your roadmap for fixing it.

I'm writing a review for my audiophile blog and for the audio forum which i'm administrating, and this bug is a blocker so I can't recommend buying Wiim as long as no fix is planned.

Most users are using Android smartphones so the UPnP protocol is the most usual way to use Wiim. It should perform as well as AirPlay.

All the best
Have you submitted a ticket to WiiM? They do visit here from time to time but for direct questions such as you ask, you may be better contacting them directly.
 
Just listening to my "gapless test" record (Pink Floyd, Live at Knebworth) via BubbleUPnP on my Samsung S22.
It is as gapless as that is possible, nothing broken here.
 
Just listening to my "gapless test" record (Pink Floyd, Live at Knebworth) via BubbleUPnP on my Samsung S22.
It is as gapless as that is possible, nothing broken here.
Prepare some short files and you will face issues yourself. Just do use nextUri methods without any transcoding to the single flow.
 
I confirm that gapless playback is broken in UPnP. And also the other playback problems mentioned above.

Please provide your roadmap for fixing it.

I'm writing a review for my audiophile blog and for the audio forum which i'm administrating, and this bug is a blocker so I can't recommend buying Wiim as long as no fix is planned.

Most users are using Android smartphones so the UPnP protocol is the most usual way to use Wiim. It should perform as well as AirPlay.

All the best
Hi Hyperion,

Thank you for your feedback. Please help send a ticket from the WiiM Home App when you have this issue so our Eng. team can troubleshoot this further. Can you also describe the UPnP server and controller you're using so we can reproduce it in our lab? Please let us know if there's certain content to produce this easier. We'll fix this issue as soon as possible. Thank you!
 
Prepare some short files and you will face issues yourself. Just do use nextUri methods without any transcoding to the single flow.
Ok, but I just wanted to mention that for my purposes everything seems to be fine. No special interest, only listening 😉
 
But, maybe someone can answer a noob question: Why do I see the WiiM twice? With different icons?
 

Attachments

  • IMG_1167.jpeg
    IMG_1167.jpeg
    38.9 KB · Views: 10
Ok, but I just wanted to mention that for my purposes everything seems to be fine. No special interest, only listening 😉
There are some aspects of those issues which can sometimes mask it completely.
You won't face it if content is being converted to the single stream.
You won't face it when a controller switches to the gapped playback method when gapless failed and tracks you've played were not gapless.
Easiest way to face issues is to prepare few gapless tracks with mixed lengths from just few seconds and play them in the loop.
 
Have you submitted a ticket to WiiM? They do visit here from time to time but for direct questions such as you ask, you may be better contacting them directly.
Take it from the right point of view ;) :

I will do visit here from time to time to see if Wiim support is taking care of this problem that has impact on 90% of the users.

In the mean time I'm writting an article abput Wiim for my Hifi blog, and for the few thousand users of the Hifi forum that i'm admin of.
 
Back
Top