New WiiM App & Firmware Updates Category

WiiM Team

Administrator
Staff member
Joined
Oct 19, 2022
Messages
437
Hi,

We created a new category with sections for our devices and WiiM Home App where we'll post the updates here so you're all informed and can give us any feedback you're experiencing here. Please note that this does not replace our support channels via the app and email at support@wiimhome.com.

We've changed the permissions so no new threads can be created but only replies on each thread to keep this category clean and organized 😎

We'll collect general feedback here so we can improve on next releases.

Thanks!
WiiM Team
 
Hi im new here. Is there any category for known/reported issues? Perhaps a GitHub link or something?

I reported a bug a couple of days ago regarding the app crashing when trying to use EQ on Android. Now the button is just entirely gone and I cant tell if its gone for good or if its being worked on or if it is yet another bug that devs are not aware of, which needs to be reported.

Would be nice if we could follow issues - that could also reduce the amount of duplicate issue reports from users, if one can see it has already been reported.

Cheers.
 
You could say the troubleshooting sections are where you’d likely find reports of existing issues - there’s nothing as structured as a known issues log.

What frequently happens is that users post an issue in the forum (hopefully after first searching) and either have their issue resolved often by being taken thru basic troubleshooting/ Q&A or are advised to use the settings/ feedback in the WiiM Home app to submit a ticket to WiiM so that their device logs can be inspected for clues.

As I understand it, WiiM’s ticketing system can automatically identify duplicate reports - indeed, it’s primarily via that that I’d guess they’d identify the impact it has on the community to help them prioritise the fix.
 
Re your particular issue, have you tried deleting and re installing the app, and power cycling if indeed not factory resetting your device?
 
Hi im new here. Is there any category for known/reported issues? Perhaps a GitHub link or something?

I reported a bug a couple of days ago regarding the app crashing when trying to use EQ on Android. Now the button is just entirely gone and I cant tell if its gone for good or if its being worked on or if it is yet another bug that devs are not aware of, which needs to be reported.

Would be nice if we could follow issues - that could also reduce the amount of duplicate issue reports from users, if one can see it has already been reported.

Cheers.
Please try @Brantome advice first. Also, if you are using an old Android phone, the PEQ screen may not display properly. Can you tell us the phone model and OS version?
 
Hi again!

I did try reinstalling the app but no luck. I have not tried to do a factory reset yet.

I am using a Samsung Galaxy S22 Ultra. Android version 14
 
I have now also tried factory resetting my device, plus I have deleted cache and data for the app, reinstalled it and got the latest update however EQ is still missing. Is there anything else I can try to do?

The EQ button used to be below the Sleep Timer button - see attached image.

1000007434.jpg
 
From the main device screen, click on the cog ⚙️ icon which takes you to device settings. EQ should be there...

View attachment 7130
Interesting. I don't have that many options for my device - I guess it is outdated and needs firmware update or something 🤔

This is what I see:
1000007435.jpg

I wrote an email to the company where I bought the device, perhaps they can help me.

Until then, is there any way for me to get an older version of the app so I can get EQ back?
 
Interesting. I don't have that many options for my device - I guess it is outdated and needs firmware update or something 🤔

This is what I see:
View attachment 7131

I wrote an email to the company where I bought the device, perhaps they can help me.

Until then, is there any way for me to get an older version of the app so I can get EQ back?
What device do you have? Can you click on the device info, that should give us more info ie. Model and firmware revision 🙏
 
Sure thing, here you go:

1000007436.jpg

Its a "Hall WIFI Streamer" by HallAudio.
I use it for my B&O speakers for wireless connection and to connect to TV.
 
This forum is primarily for the support of WiiM devices, not third party Linkplay devices. It’s therefore best that you contact Hall Audio directly as their firmware will probably differ from that on WiiM devices and their version of the Wiim app different - it may actually use the older WiiM Pod app,
 
Last edited:
This forum is primarily for the support of WiiM devices, not third party Linkplay devices. It’s therefore best that you contact Hall Audio directly as their firmware will probably differ from that on WiiM devices and their version of the Wii app different - it may actually use the older WiiM Pod app,
Gotcha - im not sure what business they have with WiiM.

OK so that explains a lot as it's not a WiiM Device at all - I'm not even sure how the WiiM Home App is able to connect to it 🤔.
I dont know, but it do support the WiiM Home App. Here is an old post on their Facebook when they started to support it - funny enough its also in relation to EQ functionality:

1000007437.jpg
 
Oh well, now im just sad that I updated the app and lost that functionality 🥲
If anyone know how I can get my hands on an older version of the app, please let me know 🙏
 
Oh well, now im just sad that I updated the app and lost that functionality 🥲
If anyone know how I can get my hands on an older version of the app, please let me know 🙏
I’d contact Hall Audio who should be able to give you a link to the apk of an earlier version.
 
OK so that explains a lot as it's not a WiiM Device at all - I'm not even sure how the WiiM Home App is able to connect to it 🤔.
Linkplay as system integrators provide the core modules and firmware to a range of third party vendors who then tailor and badge it as their own product. Similar happens with the WiiM app which doesn’t just cover WiiM hardware but a range of those third party badged Linkplay products. There’s clearly been a mismatch somewhere here, whether that be in the underlying firmware of the Hall Audio product or elsewhere.

It is possible that you might get some advice using the settings/ feedback section in the WiiM app so that’s probably worth a try as well as pressing Hall Audio for advice.
 
Back
Top