Wiim Pro Plus was working fine, but stopped working after testing another piece of equipment briefly


New member
Mar 31, 2024
I was hoping someone could help me troubleshoot a fairly new setup--the Wiim was working just fine but now I'm not getting anything out of it. A few details:

Wiim model: Wiim Pro Plus (new, using it for about a week at this point)
Streaming services used with Wiim: Tidal and Spotify
Main amp: Fosi v3 (also new)
Vintage receiver I'm testing: Yamaha CR 820 (old but very rarely used)
Speakers: Definitive D15 towers (new)
Wiim connection type: line out
Speaker to amp connectors: 14g copper

I recently nabbed a nice vintage receiver. I tested it a couple days ago with the Wiim and the speakers, and had no issues. I switched back to the Fosi for a few days and then wanted to test the receiver again, and hooked it up just like last time.

While connecting them, I accidentally connected the Wiim via line in to the line in on the receiver, ran it for a few seconds, then looked and saw my mistake and fixed the connection. I did not get any audio out of the Wiim. I tested the radio and the phono inputs instead and those both worked fine, and I tested the Wiim in both the Aux and Tape inputs, which should both work, but still nothing.

I then switched back to the Fosi, and I was no longer getting any audio from the Wiim here either.

I attempted the following (tested after each one):
1. Checked the following settings --fixed volume (still disabled), output source (line out)
2. Rebooted through the app
1. Power cycled (aka unplugged) the Wiim, the amp, and my phone
2. Fiddled with EQ, volume settings across phone/Wiim/amp, etc
3. Cut new ends on the copper connectors and reconnected

Unfortunately, none of these have worked. Each time I am able to connect to the Wiim via my phone and it appears everything is playing normally --if I play through Tidal/Spotify and then go into the Wiim app, the Wiim app correctly shows what is (supposedly) playing.

Anything else I can try? Given the phono and radio worked fine on the vintage receiver, and given the problem persisted across both the receiver and the Fosi, I feel like something must have gone wrong with the Wiim or the amp, but I can't figure out what. The only thing I did wrong was briefly connected to the line in on the Wiim versus the line out--is that really enough to mess it up?? The amp still powers on normally and has the power light on, there's not much else I can do to test it besides that.

Thanks for any tips and tricks!
Last edited: