WiiM Pro setup problem

Jdamberger1

Senior Member
Joined
Nov 30, 2022
Messages
43
I currently have two WiiM Minis, so I am familiar with setup. I set it up out of the box using ethernet connection. When I plugged in the power, I already had the Wiizm app open. The app did not see the WiiM Pro. It timed out. As directed, I pushed the arrow forward button until the status light flashed and repeated setup. It still did not see the WiiM Pro. It was then I turned off my VPN on my phone. I rebooted my phone, rebooted the WiiM Pro and setup was then successful. I use my VPN everyday with my two WiiM Mini s with no issue, but the Pro did not like it during setup. I hope this information helps someone else. Turn off you VPN during setup on the WiiM Pro.
 
@Jdamberger1 did you try downloading the latest WiiM Home app? The latest WiiM App is compatible with WiiM Mini and WiiM Pro.
 
@Jdamberger1 did you try downloading the latest WiiM Home app? The latest WiiM App is compatible with WiiM Mini and WiiM Pro.
Yes, I had the latest version of the app. The moment I turned off my VPN and rebooted my Android phone and the WiiM Pro, the app found the WiiM Pro immediately.
 
I had the same exact problem earlier when my wimm pro arrived. From the get go, I connected the wimm via ethernet and tried to set it up but the app said it couldn't detect it and asked me to press the play button 3 or more secs until it blinks but still couldn't be detected. Then I tried connecting via 5Ghz wifi and it was instantly detected so I connected to that. Wifi was pretty stable but since I already have the ethernet prepared for wimm I reconnected it but it did not stop playing while transitioning from wifi to ethernet (I was expecting the stream to stop or hiccup at least). So ethernet works but not for setting up the wimm pro initially.
 
I had the same exact problem earlier when my wimm pro arrived. From the get go, I connected the wimm via ethernet and tried to set it up but the app said it couldn't detect it and asked me to press the play button 3 or more secs until it blinks but still couldn't be detected. Then I tried connecting via 5Ghz wifi and it was instantly detected so I connected to that. Wifi was pretty stable but since I already have the ethernet prepared for wimm I reconnected it but it did not stop playing while transitioning from wifi to ethernet (I was expecting the stream to stop or hiccup at least). So ethernet works but not for setting up the wimm pro initially.
I did set mine up from the getgo with ethernet, no wifi. Had same issue of not seeing it. Turned off VPN on my Android phone, rebooted phone and WiiM Pro. After reboots, launched WiiM Home app and it saw the WiiM Pro immediately.
 
I’m trying to determine if my source is ethernet or wifi. In settings, audio input screen only shows wifi, bluetooth, spdif in, line in. Ethernet not listed. Does anyone know how to confirm ethernet as the stream source. Thanks.
 
I’m trying to determine if my source is ethernet or wifi. In settings, audio input screen only shows wifi, bluetooth, spdif in, line in. Ethernet not listed. Does anyone know how to confirm ethernet as the stream source. Thanks.
If you go into the device settings wifi status page, it’ll just show the IP, MAC and DNS info. If it was using the wifi connection, you’ll get a full page of info on signal strength etc. Perhaps they need to change ”wifi status” label to network or similar
 
If you go into the device settings wifi status page, it’ll just show the IP, MAC and DNS info. If it was using the wifi connection, you’ll get a full page of info on signal strength etc. Perhaps they need to change ”wifi status” label to network or similar
Thanks, that is what I see. I’m sure this will confuse others. Your post is very helpful.
 
Wiim needs to add one network setting turning off WiFi on the Pro.
 
The support page here: https://wiim.freshdesk.com/support/solutions/articles/72000593468-how-to-disable-wi-fi shows there should be a way to disable wifi, however, I do not see these options on my app. I believe I have the current firmware and updated app:

4.8.504937
2.3.8.23011610

I am thinking this means I am connecting via wifi and not Ethernet.
That screen is just for a Pro - do you have that and the latest app version or a Mini? A Mini without wifi is basically a brick 😜😂
 
I don't see that option to Enable WiFi. I see:

Wi-Fi Roaming

and then

Enable iPv6

I'm guessing it is not detecting that I have an Ethernet cable attached for some reason.
 
Weird. Have you tried using a different Ethernet cable? Does your router see the Ethernet connected Wiim?
 
I fixed it. I unplugged and replugged the Ethernet cable on both ends and rebooted the WiiM and now I have Ethernet connection and was able to disable WiFi.

Thanks for the help everyone. I guess when in doubt unplug everything and start all over.
 
I have had similar struggles with the ethernet connection. Following the advice above, changing cable, rebooting, etc., I believe that I have an ethernet connection, with the network status page showing IP, Device MAC, Preferred DNS Sever (on/green), and Enable Wi-Fi off.

I was thinking that disconnecting the ethernet cable may result in a stoppage, interruption, or change in the quality of music playing via Spotify Connect, but not so. It soldiered on with no noticeable change (to a cheap but convenient test speaker using line-out RCA cables. The Network Status after disconnecting the ethernet cable presents only the IP and Device MAC.

Did I indeed have a network connection, and notwithstanding the choice of Wi-Fi "off, " the music seamlessly continued? If I didn't have an ethernet connection, I would appreciate comments on achieving a successful connection and how to confirm its presence.

Thank you.
 
You should see Ethernet as a choice at the bottom of the screen when you click on "Browse" in the app.
 
Back
Top