WiiM Pro suddenly will not connect via Ethernet

JSA1971

Active member
Joined
Dec 25, 2022
Messages
37
Location
Canada
Hello All,
I setup my Pro last week via the WiiM Home app and all went perfectly well. I connected to my home wifi, the unit downloaded the latest firmware and rebooted. After the reboot I connected the Pro via Ethernet Cable, the Pro acquired an IP address from my router and everything worked.

Today, my Pro will only connect to my wifi. Anyone else having this issue?

As an aside, the WiiM Home App has also greyed out the ability to rename the unit.

Any help with the Ethernet connection suddenly dropping and disappearing would be greatly appreciated.

Thanks!
 
So, tried the old tested and true “unplug, count to 10, and plug back in” method and the Ethernet connection is back. However, this shouldn’t need to be done if I don’t use the WiiM for a few days. Please fix this WiiM.

Also, the “Rename” prompt is still greyed out and when I click it I get a message to use the Home app to rename… but I’m already in the Home App. I’m sure just a bug that needs to be addressed.
 
I'm having a similar issue. My WiiM Pro just won't seem to stay powered on. I programmed to keep status lights on and to never enter standby mode. It won't stay on and when it randomly turns off it will not turn on by any button press. I also am unable to simply unplug and restart the unit. Its not until I disconnect near everything that I finally get the lights to turn back on and even then it usually won't stay on for more than several seconds or a few minutes. It seems like a miracle when I can actually get this thing to work. At times it will function fine however not as often as would be close to desirable. I really hope we can get this fixed.
 
My pro was unresponsive this morning so I unplugged it and rebooted it. I immediately got a notification that there was a firmware update. This update now includes the ability to disable wifi, and indicates that you can only do so if an Ethernet connection is available, there’s also a WiiM Home app update. The rename unit issue still exists though. We shall see if the Ethernet issue continues.
 
I'm having a similar issue. My WiiM Pro just won't seem to stay powered on. I programmed to keep status lights on and to never enter standby mode. It won't stay on and when it randomly turns off it will not turn on by any button press. I also am unable to simply unplug and restart the unit. Its not until I disconnect near everything that I finally get the lights to turn back on and even then it usually won't stay on for more than several seconds or a few minutes. It seems like a miracle when I can actually get this thing to work. At times it will function fine however not as often as would be close to desirable. I really hope we can get this fixed.
Sorry to hear you're experiencing this. Please send us a ticket through the app and we'll take a look: Settings > Feedback.
 
The latest firmware 3558 broke the standby it doesn’t work anymore. Now, pro is always on. It was working prior to this update.
 
I have disabled WiFi on my Android. Ethernet is selected as input. Steady white function light, which according to the user manual means "connected to network." I have powered the (not so) Pro down and up several times. The app won't budge off "your phone ...doesn't enable Wi-Fi connection. Please enable Wi-Fi connection then search again" unless I restart my phone.

What should I try next? Reset the (not so) Pro?

Thanks to those who have contributed to this so far. It has been helpful. Too bad we have to be involuntary beta testers.
 
Back
Top